Tuesday, June 03, 2008

QuickTime 7.4.5 for 10.4.11 disabled audio on FLIP Video (3ivx codec) - get Perian

It was broken in April 5th! How time flies. I only noticed today. It's a known problem with QT 7.4.5 and 10.4.11, but there hasn't been much noise. Neither Apple nor FLIP has been particularly helpful ...
Apple - Support - Discussions - When will Apple fix QT 7.4.5: no sound ...

...FLIP uses the 3ivx codec. I recall that the version they were distributing last I checked was described by 3ivx as having severe security issues. 3ivx distributed a newer version but FLIP doesn't distribute it.

It may be that Apple's 7.4.5 Quicktime update fix took care of the security problem -- by deliberately or unavoidably disabling the 3ivx codec. If so, that would be, shall we say, not very nice of them.

Under the circumstances it would have been nice of Apple to have also created a kb article about the problem.

Of course FLIP should also have created a kb article, and by now they should have had a fix.

It's noteworthy though, how few complaints there are in this forum. Evidently the group of people who are using FLIP video with 10.4.11 and applying security fixes and who know about discussion forums is really, really, tiny...
So if my FLIP camcorder stops working because the software is broken, can I make a warranty claim?

No, I didn't think so.

Update 6/5/08: If you try exporting from QT Pro, you'll see no options to export the audio stream. QT Pro is not "aware" of an audio component.

Update 6/5/08b: I installed the 3ivx.com 5.0.2 codec (trial version). It doesn't work either. Happily, we're seeing more complaints on the 3ivx forum. Frustrated users may wish to install the 3ivx s/w, then register for the forum and complain it doesn't work.

Update 6/5/08c: I uninstalled 3ivx.com 5.0.2 and installed the Perian preference pane codec collection. It works. I'm able to export to Apple Intermediate Codec. Uninstalling the 3ivx.com codec will disable the Flip import utility, you will need to drag files over by hand. The import utility reads Flip metadata and puts the image acquisition date in the file name, I'm sorry to lose that.

A pox on Apple, PureDigital and 3ivx.com alike. Blessings to the Perian LGPL development team. (Now if only they'd use something other than PayPal for donations ...)

4 comments:

d.w. said...

It may just be that gadget early-adopters are OS early-adopters too (i.e. probably far more people using Flip cams with Leopard than Tiger)

ian said...

Have you heard of any issues with OSX and not being able to delete files from camera. I'm on my second Flip not using the Flip software at all. Record,drag from DCIM/100 folder to desktop, delete file from DCIM/100 folder, unmount camera and though there are no movie on the camera the time is forever removed from the Flip camera. So, it says I have 49 min remaining but there is nothing on the camera.

John Gordon said...

Ian, haven't seen that. I'd suggest downloading and reapplying the ROM update from the Flip site, and the latest software version.

Otherwise send a support email to Flip.

Fat Girl TV said...

When you drag a video file off of the Flip to delete it, you have to EMPTY the trash on your computer before removing the camera. Common problem. Flip support says they hear it all the time. So, drag your video into the trash on your computer, then empty the trash BEFORE removing the camera. Turn it on and wa-la! You have your 60 minutes back. Easy cheesy. Now, if there was just such an easy fix for the horrible audio. P.S. I have Tiger and was an early adopter.