Monday, June 01, 2009

Cannot remove (delete) a SharePoint List reference from Outlook 2007 - a fix

One of the less wise things I’ve done in the past year was to migrate to Office 2007, and, in particular, to try using any of the new features of Outlook 2007.

I’ve seen some awful software in my day, but Outlook 2007 is in a class of of its own.

For example, I once tried subscribing to a SharePoint list from Outlook, so Outlook would, in theory, give me a synchronized offline view of the list.

I no longer recall the immediate problems it caused me, but I do remember I couldn’t remove it. At best I could partly disable the synchronization. The list reference lived on in my Account Settings.

I left it there, hoping the long promised SP2 would help. I thought I could live with it.

Then my sojourn into the 9th circle of IT Hell began. After week 3 of network lockouts I began methodically removing anything that could trigger an Active Directory authentication process, including any reference to anything hosted on Sharepoint. That included any referenced calendars, feeds, etc. Including my old Sharepoint List reference that could be seen in File:Data File Management:Account Settings:SharePoint Lists.

After some searching I found a good TechNet posting that referenced another relevant article.

There were two different fixes for this problem, but one was to remove a dangling reference in the send/receive settings. I remembered trying this last year, but since I’d just applied Office SP 2 I gave it a go and unchecked these items:


This time removing Sharepoint from the send/receive group worked. I was able to go to the Data File account settings and remove the Sharepoint Lists item and the corresponding Data File – and they didn’t return!


Naturally it wasn’t totally smooth. After I submitted my changes to the send/receive group an old friend returned … the IPM.Note.Microsoft.Conversation.Region set of dialogs ...


I think these are back because, as a part of my attempt to reduce Active Directory authentication, I’d recently removed Office Communicator 2007. When you do that you find the uninstall leaves some registry keys behind, and you get these error messages until you reinstall Communicator or manually remove the registry keys ...


SamB said...

THANK YOU. Awesome.

SteveT said...

Nice one Gordon, that's been p155ing me off for a couple of years, kept asking me to authenticate to a server we dumped a long time ago.

I can hardly believe it's gone.

WooT :-)

David Shipley said...

Thank you so much for this. I cannot believe its 2015 and we still have this issue!